Thursday, February 28, 2008

Repairing Archos V2 Jukebox Recorder headphone jack

In the past I wrote an article about bad design and unreliability of Archos devices. I thought I should document one of my successful repairs for the benefit of others faced with the same problem. This problem exists on the Archos V2 Jukebox Recorder (with blue plastic bumpers in the corners and an internal lithium-ion battery) and almost certainly also on the Archos FM Recorder. It manifests itself as occasional disconnection (silence) of left and/or right headphone outputs. The problem is due to a small circuit board breaking off the pins of the headphone jack.

You first need to open up the device. The Multimedia Jukebox has the same case and there is a good guide on how to disassemble it. Basically, there are two screws on the top (small side above the screen), two on the bottom, and metal clips sticking out from the metal part of the case holding the plastic part. You can also slide out the hard drive and battery, but some bending of the top end of the metal part of the case is probably necessary for that. The result should be:
Now you can see the little circuit board that's soldered to the headphone jack pins. Breaks in the solder are probably not wide open; the sides of the crack are probably touching. I found I could easily move the small board away, leading to this picture:

Now, one could just solder the small board back and close up the device. I chose to go further, desoldering the metal part of the case from the circuit board so that I could access the other side of the main circuit board. Some of these solder connections were already broken, often ripping off some of the copper. I then removed he headphone jack, inspected it to make sure it was okay, and glued it back with epoxy so that it wouldn't move and stress the connections. I'm not sure if glue is the best idea in case the jack breaks. I put a short length of electronic component lead (thin solderable wire) in the holes alongside the headphone jack pins to reinforce the solder, and I soldered the small board to the headphone jack. Here is a photo of the underside of the board with the headphone jack removed:

While that side is exposed, it would probably be a good idea to inspect the charger jack and battery contacts, and clean the battery contacts. The charger jack is mounted on its side. If you look at the full version of the photo you can see how the side that's supposed to be touching the circuit board is actually to the right. This makes the jack far more vulnerable to stresses from plugging stuff in. I later had to repair the connection from the bottom/outer pin (which goes to the right) to the small jumper wire that connects it to the circuit board. The battery contacts can get dirty, making it seem as if the battery is worn out. I cleaned them using an abrasive pen eraser. Some people have reported bent contacts, so it is a good idea to make sure that they have not been bent. Later, you can clean the battery and the contacts at the other end. If the battery is old you could replace it, but if it seems to perform poorly it's quite possible that the contacts were dirty and it will perform acceptably after they are cleaned.

Finally, while reattaching the circuit board to the metal part of the case I fixed the solder connections. Where the copper on the circuit board was broken I had to clean off surrounding copper and solder to that. I found that desoldering braid was best for making a reinforced connection. The trickiest part of the reassembly was the top-back part of the case. One has to bend it to put in the hard drive and battery, and bending it back afterwards can be a problem. It might make most sense to put those in before soldering the circuit board to the case.

Tuesday, February 26, 2008

My photos from the Bruce Peninsula

The Bruce Peninsula is the narrow strip of land separating Lake Huron and Georgian Bay. The Georgian Bay side has cliffs and very clear water. The best parts are in the Bruce Peninsula National Park. The Bruce Trail goes through this area and provides access to many interesting sights. After the Pacific coast and Rocky Mountains, it's my favourite part of Canada.

I've uploaded a lot of photos of the area to Panoramio a site which allows you to view photos on a map or in Google Earth. You can view all my photos tagged "Bruce Peninsula", view my photos from the area on a Google Maps type map or get the .KML with for all photos by me, open that in Google Earth and then search for "Tobermory, ON" to get to the area.

How I fixed the layout editor issue

I tried to edit my layout but found that the editor is broken. Part of the layout was cut off and there was no scrollbar. There were no links to add page elements. If I placed my mouse above a page element I would get the four arrows cursor for moving but I couldn't move elements. This problem existed in Firefox without any extensions and in Internet Explorer 7.0. I found a known issue which seemed to relate. I could indeed scroll in IE by selecting text, but that didn't work in Firefox, and I was still only able to only edit or delete elements.

I fixed the issue by going to "Pick New Template" and reselecting my current one. The layout editor works perfectly now. I wish I could add this as a comment to that known issue page.

Sunday, February 24, 2008

Customizing Vista Explorer's Details pane.

I notice that when I select a JPEG file in Vista, Explorer shows a thumbnail and some information about the file in the Details pane on the bottom. This is a good idea. However, I cannot understand how someone could chose to display those particular details. My main objection is the camera model and camera manufacturer field. I know what kind of camera I have, and when viewing others' images I don't care about the camera brand that much either. It would make far more sense to devote that space to information like exposure time and F-stop. However, you cannot change that from the GUI.

Yes, I found out how to change this by editing PreviewDetails in HKCR\SystemFileAssociations\.jpg and that's not too hard for me. I just find it ridiculous and idiotic to have such useless defaults which cannot be changed except by editing a string in the registry.

Manually moving a Vista NTFS partition

I spent a big part of yesterday manually moving a Vista NTFS partition. It was frustrating but I learnt something.

The obvious part is moving the data. The new and old positions didn't overlap, so I could just create a new partition and copy the data. I booted a Ubuntu CD in single user mode, created a partition with fdisk and copied the data with dd, specifying a large block size to speed up the copy. I made the new partition active (boot flag), the old partition un-active and I hid the old partition by changing its type to 0x17. This results in a readable but unbootable partition.

The first issue boot issue is the Vista boot configuration data store (which may be edited with bcdedit in Vista). Booting off a Vista DVD and running the automated startup repair can fix this; Vista will add the partition as a "(recovered)" entry to the boot menu. However, Partition Saving seems like a better choice because it will allow you to alter all the entries. After this is fixed, Vista would appear to boot ok but after logging in practically nothing would work because the moved partition is mounted as something other than C:.

Vista's automated startup repair doesn't seem to be able to fix the drive letter issue, but it may be fixed manually by running regedit, loading the system hive and editing entries in MountedDevices. Partition Saving can quickly and easily fix the problem, and so I recommend it for both of these problems. After this, everything may seem to work, but that's deceptive because the boot is still using parts of the old partition. If the partitions get out of sync, mysterious boot problems can occur. If you're lucky, you'd get "A disk read error occurred" followed by "Press Ctrl+Alt+Del to restart", but the boot could simply hang with no error message.

In order to fix the boot sector problem, I looked at information about the XP boot sector and considered trying to understand where it might be failing or even trace through the code. After I learnt that the boot sector loads additional sectors following it and noted that some error messages aren't used by the boot sector itself I realized that the code it loads might be failing and just using the error messages in the boot sector. I found a blog post about avoiding "disk read error occurred" after resizing. That was not it; the geometry was correct. However, it drew my attention to "Number of Hidden Sectors" at offset 0x1C in the boot sector. This had to be the sector number that the boot sector is at. It was still pointing to the old partition. After fixing that with a disk editor, everything seemed fine.

There was one remaining issue I remembered: there was a backup boot sector. I ran TestDisk and it found that the boot sector differed from its backup now. I then told it to copy it to the backup. (TestDisk is great utility for undeleting partitions. The boot sector backup saved me once when an attempt to install MS-DOS 6.22 started reformatting the HD and overwrote the boot sector.)

While doing all this I also learnt about Bootrec on the Vista DVD and bootsect.exe. While both of these Microsoft utilites can rewrite the boot sector, they don't seem to fix the sector number at offset 0x1C. Chkdsk is also useless here; it won't notice that anything is wrong. All this makes me very disappointed about Microsoft's automated repair tools. They did do one thing right however: the Vista recovery environment is like a LiveDVD which allows you to use some standard Vista tools like regedit.

Saturday, February 23, 2008

There's too much spam on Yahoo Messenger

There's too much spam on Yahoo Messenger, and Yahoo seems to do nothing about it. It's all very similar. The accounts names look as if they're generated by the same algorithm. Each message includes one randomly selected emoticon. Finally, and most importantly, each message contains the URL of some web site with the characters of the URL alternating with non-printing characters, as if I was viewing UTF-16 as 8-bit.

Messenger spam is especially annoying because the message results in an open window "in my face". Yahoo seems to be able to handle e-mail spam; I get practically none. So why cannot they handle Messenger spam? I've already set Messenger to not allow Yahoo web sites to show I'm online. So the only option available to me is "Ignore anyone who is not on my Messenger list". It's too bad that I've been forced to set that, but there are plenty of other ways to contact me.

Edit (Feb 26th): I had a Yahoo IM link in my profile on Blogger. I wonder how much of the spam was because of that.

Wednesday, February 20, 2008

Photos of the total lunar eclipse

I just took some photos of the total lunar eclipse using my Olympus C-770 Ultra Zoom camera. 10x optical zoom is insufficient for photos of the moon. I ended up using the "Super Zoom" mode which crops the image to 1600x1200 while possibly zooming a bit more. I'm not really happy with these images, but I guess they're not too bad based on friends' reactions and considering they come from a consumer camera.

Conflict between Redirect Remover and Secure Login Firefox extensions

Recently I found Firefox was crashing regularly. It crashed more often than Netscape or IE ever did. Then one time I finally found how to reproduce the crash. The link to one story on Reddit would always make Firefox hesitate and promptly crash. I first noticed this because the story was at the top of the Reddit home page. Fortunately, the crash also happened on the story's comments page, and so it didn't depend on the layout of the home page.

At first it seemed like a problem with Redirect Remover because that extension was active on the link, and its special cursor remained even after I moved it off the link. However, then I thought that it might be a conflict with another extension, and through a binary search I found that it was a conflict with Secure Login. In order for the crash to occur, both extensions needed to be enabled, the page couldn't be loaded from a local file, I had to be logged in to Reddit, and a password had to be saved for Finally I found a workaround: disabling "Automatically search for login data and highlight form fields" in Secure Login. I've sent information to authors of both extensions and I've submitted a Firefox bug report via Talkback. In the meantime, the workaround isn't a problem and Firefox is totally stable.

Tuesday, February 19, 2008

Fidel Castro did a good job

It seems that Fidel Castro's government did a good job in Cuba. If one compares Cuba with other large independent countries in the Caribbean, one notes that Cuba is doing better in most ways. A comparison with developed countries or the territories of developed countries would not be fair. However, Cuba beats Puerto Rico (a territory of the US) in many categories and it even manages to beat the US in infant mortality, literacy and some other categories. This is all despite the US embargo and the collapse of the Soviet Union. All this makes Cuba seem like a socialist success story.

I'm amazed by how some people, especially Americans, attack Castro and Cuba. It seems like an irrational hatred of "communism" and attachment to democracy. The government works. It's like those people value the ability to complain about the government more than the performance of the government. One has to consider what has happened to other countries in the region to get a realistic picture of the alternatives. Haiti and the Dominican Republic have had democratic elections but also coups and other violence. It would probably be unreasonable to imagine that Cuba would have been a stable democracy (like the US or Western Europe) all this time if it wasn't for Castro.

Finally here's some information from the CIA World Factbook. Remember, this comes from the US government. It is not "communist propaganda". The country names link to the pages for that country at the CIA site.
HaitiPuerto RicoUSA
GDP per
GDP real
Public debt
% of GDP

Saturday, February 09, 2008

Generallization fallacies

Quite often, people seem to believe that some method, model or system of beliefs is good because they see instances in which it is good. This can be very false and deceptive, and it is sometimes used as a tool to spread and sell garbage. There are several traps involved here:
  • Does even a part of it work reliably? It's easy enough to find a few examples which support something, but that doesn't prove anything. For example someone trying to claim that their stock picking scheme works has a huge amount of market data they can use to try to find good supporting examples. People can also deceive themselves because even a terrible model may sometimes fit reality through coincidence.
  • If a part works that doesn't prove the rest. It's easy to package something accurate with a load of garbage and try to sell the whole load of garbage as if it was accurate. Some people will look at the accurate parts and conclude that everything under the same label is accurate.
  • If something works and has a new name that doesn't mean it's unique. It's easy enough to try to market something as "new" or "secret". Sure, the idea might work but it might be overpriced and a deceptive source may deceive in other ways. It probably makes more sense to find a source which acknowledges the true history of the idea.
  • Proprietary jargon can make something seem unique, sophisticated and special. Use of proprietary jargon can also draw people into a particular system. It is much better to use standard terms. They make understanding easier and open one up to many more sources of information.